
1

Warsztaty 

Cadence Virtuoso

Materiały pomocnicze do zajęć

SKN CHIP

Gdańsk, maj 2023

© B. Pankiewicz



2

Plan warsztatów

• Pierwsze logowanie, uruchomienie oraz ogólne 

informacje o Cadence Virtuoso.

• Wstępne informacje dotyczące projektowania układów 

elektronicznych w wersjach dyskretnych i scalonych.

• Proces technologiczny CMOS, bardzo wstępne 

informacje wystarczające do rozpoczęcia 

projektowania.

• Symulacja elektryczna – przypomnienie głównych 

właściwości.

• Wstępne informacje o topografii układów scalonych.

• Ekstrakcja topografii i symulacje po ekstrakcji.
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Plan warsztatów c.d.

• Co to jest PDK?

• Różne style projektowania IC.

• Wykonanie pierwszej symulacji 

elektrycznej.

• Wykonanie symulacji podstawowego 

prostego układu cyfrowego (bramka) z 

użyciem TestBencha

• Wykonanie projektu topografii bramki.

• Wykonanie ekstrakcji i symulacji po 

ekstrakcji.
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Wymagane zasoby

(wszystko jest dostępne w KSMI)

• Środowisko CAD Cadence Virtuoso

• Konto w systemie komputerowym KSMI wraz z 

odpowiednimi uprawnieniami

• Dostęp do komputerów w sieci katedry

• Opcjonalnie konto na komputerze „staff” do 

zdalnego połączenia spoza KSMI

PKM, LKM – prawy/lewy klawisz myszki



Pierwsze logowanie i uruchomienie 

Cadence Virtuoso wraz z GPDK 45nm
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• Uruchamiamy dowolny komputer znajdujący się w sieci KSMI a następnie 

uruchamiamy Podłączenie Pulpitu zdalnego.  W polu Komputer wpisujemy 

pglaser2, wybieramy Pokaż opcje i w zakładce Ekran należy wybrać grafikę 24 

bitową oraz wielkość okna terminala taką jaką chcemy używać.

• Klikamy Podłącz.

• W kolejnym oknie wpisujemy nazwę użytkownika i hasło i potwierdzamy OK.



Pierwsze logowanie i uruchomienie c.d.
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• Powinien pojawić się pulpit zdalny komputera pglaser2, jesteśmy zalogowani lecz 

przed pierwszym/kolejnym uruchomieniem należy skonfigurować środowisko oraz 

PDK wybranej technologii. 

• Pierwsze zalogowanie może wymagać także przejścia przez ustawienia wstępne, 

wówczas należy wybrać język angielski oraz polską klawiaturę (wartości domyślne) i 

wszystkie ewentualne poradniki pozamykać.

• Kończenie sesji należy KONIECZNIE wykonać poprzez przycisk zasilania/wybranie 

numeru indeksu oraz polecenie Log Out. Jeśli tego nie wykonamy sesja jest tylko 

zawieszona i ponowne uruchomienie połączenia zdalnego może powołać nową sesję a 

takie nawarstwienie nowych sesji blokuje pracę. Gdyby tak się zdarzyło należy zabić 

wszystkie własne sesje poleceniem:

pkill –SIGKILL -u nazwa_użytkownika

• Wcześniej można sprawdzić kto ma otwarte sesje 

poleceniem:

who



Pierwsze logowanie i uruchomienie c.d.
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• Polecenia wydawane są w terminalu, który uruchamia się poprzez PKM na pulpicie.

• Koniecznie, przy pierwszym logowaniu należy zmienić hasło domyślne, polecenie do 

zmiany hasła:

passwd

i to nowe hasło koniecznie zapamiętać!



Pierwsze logowanie i uruchomienie c.d.
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• Zasadniczo pliki projektu powinny być umieszczane w jego katalogu roboczym, aby to 

zrobić można skorzystać z następujących poleceń wydawanych w terminalu:

cd nazwa_katalogu – przejście do danego katalogu, bez nazwy przejście do domowego

katalog domowy w sieci KSMI tworzony jest wg wzoru: /home2/s_xyyy gdzie:

x – pierwsza litera imienia, yyy – nazwisko, pisane małymi literami bez polskich znaków 

diakrytycznych

pwd – odczyt położenia bieżącego katalogu

mkdir nazwa_katalogu – utworzenie nowego katalogu

ls – wylistowanie zawartości bieżącego katalogu

• Polecenia są czułe na wielkość liter i mają szereg dodatkowych parametrów. Podanie 

dodatkowego parametru --help (np. ls --help) wypisuje pomoc do danego 

polecenia.

• Nazwy katalogów i plików można podawać zarówno bezwzględnie (od korzenia czyli 

od znaku /) lub względnie (w stosunku do katalogu bieżącego). Pojedyncza kropka 

oznacza katalog bieżący a podwójna katalog nadrzędny.



Kilka często używanych poleceń linux
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Uruchomienie w tle przeglądarki internetowej Mozilla Firefox wraz z jednoczesnym wczytaniem wszystkich plików typu pdf z katalogu 

bieżącego: 

firefox *.pdf &

Spakowanie całego katalogu o nazwie podkatalog do jednego pliku o nazwie podkatalog.tar.gz (poleceniem tar) i jego skompresowanie 

poleceniem gzip: 

tar -zcvf podkatalog.tar.gz podkatalog

Rozpakowanie spakowanego i skompresowanego archiwum o nazwie podkatalog.tar.gz do bieżącego katalogu: 

tar -zxvf podkatalog.tar.gz lub do dowolnego innego katalogu: 

tar -zxvf podkatalog.tar.gz -C /home2/s_test/katalog_docelowy/

Zdalne kopiowanie plików pomiędzy komputerami z systemem Linux pracującymi w sieci możliwe jest poprzez polecenie scp. W 

poniższym przykładzie użytkownik s_test (musi on posiadać konta na obu komputerach fpgalab101 i pglaser2) wykonuje kopię katalogu 

folder_zrodlowy wraz ze wszystkimi plikami i podkatalogami z komputera fpgalab101 na komputer pglaser2 do katalogu 

folder_docelowy. Zarówno folder_zrodlowy jak i folder_docelowy umieszczone są w katalogach domowych a użytkownik s_test jest 

obecnie zalogowany do komputera fpgalab101: 

scp -r folder_zrodlowy s_test@pglaser2:/home2/s_test/folder_docelowy 

Sprawdzenie wykorzystania systemu dyskowego: 

df -h 

Sprawdzenie zajętości bieżącego katalogu (wraz z podkatalogami): 

du –sh . 

Sprawdzenie zajętości z wyszczególnieniem zajętości dla poszczególnych podkatalogów: 

du –h . 

Więcej przykładów można znaleźć w zasobach Internetu, np. tu:

http://www.ue.eti.pg.gda.pl/~bpa/linux/polecenia.pdf



Wykonanie kopii projektu i jej 

odtworzenie na innym komputerze
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Wykonanie kopii projektu Cadence Virtuoso możliwe jest przez skopiowanie całego katalogu w którym ten projekt jest umieszczony. 

Kopiowane są wówczas zarówno zaprojektowane komórki jak i konfiguracja środowiska. Można również skopiować podkatalog 

zawierający zaprojektowaną bibliotekę, wówczas możliwe jest jej przenoszenie wyłącznie do projektów o takich samych ustawieniach

technologicznych. Kopia całego katalogu projektu, zakładamy że jesteśmy w katalogu głównym tego projektu: 

tar -zcvf projekt.tar.gz *

Wykonanie wyłącznie kopii biblioteki o nazwie LIB :

tar -zcvf LIB.tar.gz LIB

Wykonanie kopii pomiędzy komputerami (założono zalogowanie do komputera źródłowego fpgalab101, można to zrobić zdalnie z 

dowolnego komputera poleceniem:

ssh –X s_xyyy@fpgalab101), kopiujemy plik projekt.tar.gz z komputera fpgalab101 na komputer pglaser2, zakładana nazwa 

użytkownika s_xyyy:

scp projekt.tar.gz s_xyyy@pglaser2:/home2/s_xyyy/

Logujemy się do komputera docelowego pglaser2 a następnie tworzymy katalog kopii projektu i rozpakowujemy pliki: 

mkdir /home2/s_xyyy/designs/gpdk045/p_kopia

tar -zxvf projekt.tar.gz -C /home2/s_xyy/designs/gpdk045/p_kopia/

Pozostało tylko sprawdzenie czy skopiowany projekt da się uruchomić. Konfigurujemy środowisko Cadence Virtuoso:

source /eda/cadence/2022-23/analog.csh wchodzimy do katalogu projektu:

cd /home2/s_xyy/designs/gpdk045/p_kopia/ oraz jeśli w komputerze docelowym położenie katalogów nie jest

identyczne jak w źródłowym musimy wyedytować plik cds.lib i wykonać korekt ścieżek:

gedit cds.lib oraz po zapisaniu pliku uruchamiamy Cadence Virtuoso:

virtuoso &



Pierwsze logowanie i uruchomienie c.d.
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• Konfiguracja środowiska Cadence Virtuoso po każdym nowym uruchomieniu 

terminala: 

source /eda/cadence/2022-23/analog.csh

• Jednokrotna konfiguracja danego PDK w katalogu roboczym:

Należy postępować zgodnie z instrukcją dla GPDK045 na stronie:

http://www.ue.eti.pg.gda.pl/~bpa/cadence/gpdk.html

• Po skonfigurowaniu środowiska i PDK można uruchomić oprogramowanie poleceniem:

virtuoso &

• Powinno pojawić się 1 (tzw. Okno CIW) lub 2 okna (CIW i Library Manager).

• Możliwe jest również logowanie zdalne, wymagane jest wówczas dodatkowe konto na 

komputerze staff. Instrukcja połączenia jest dostępna tu: 

http://www.ue.eti.pg.gda.pl/~bpa/ogolne/zdalne_polaczenie, należy 

wybrać połączenie wg scenariusza D) z podaniem jako docelowego adresu IP 

komputera pglaser2 (pozostałe scenariusze zostają stopniowo wycofywane)
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Pierwsze symulacje elektryczne

14

• Jeśli nie uruchomił się automatycznie uruchamiamy Library Manager, 

menu: Tools->Library manager.

• Tworzymy nową bibliotekę, menu: File->New->Library, podajemy własną nazwę 

np. SKN_CHIP , wybieramy Attach to an existing technology library oraz gpdk045.

• Nowo utworzona biblioteka powinna być widoczna  w zakładce Library.



Pierwsze symulacje elektryczne c.d.

15

• Projekty są zorganizowane w postaci bibliotek. W bibliotekach umieszczone są 

komórki, które mają swoje „widoki”. Komórka może mieć kilka widoków (schemat, 

symbol, topografia, opis behawioralny i inne).

• Tworzymy nową bibliotekę, z poziomu Library Manager, menu: File->New-
>Library, podajemy własną nazwę np. SKN_CHIP , wybieramy Attach to an 

existing technology library oraz gpdk045.

• Nowo utworzona biblioteka powinna być widoczna  w zakładce Library.



Pierwsze symulacje elektryczne c.d.
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• Tworzymy nowy schemat w bibliotece SKN_CHIP przy użyciu Library Manager.

• Menu: File->New->Cell View, wypełniamy jak na rysunku i klikamy OK.

• Otworzy się pusty edytor schematów. Następnie wprowadzamy schemat jak na 

rysunku.



Pierwsze symulacje elektryczne c.d.
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Pierwsze symulacje elektryczne c.d.
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Rodzaje symulacji elektrycznych
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• Każdy symulator elektryczny ma zestaw dostępnych typów symulacji, które jest w 

stanie wykonać. 

• Podstawowe rodzaje analiz to: dc (stałoprądowa), ac (małosygnałowa 

częstotliwościowe) oraz tran (czasowa).

• Wszystkie pozostałe analizy są albo rozszerzeniem albo dalszą interpretacją wyżej 

wymienionych.



Analiza stałoprądowa DC
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Analiza DC wykonuje sparametryzowane obliczenie punktu pracy 
układu. Elementy inercyjne są pomijane (C -> rozwacie, L-> 
zwarcie), elementy nieliniowe zachowują nieliniowy charakter. 
Argumentem tej analizy jest zmieniany parametr (jest on 
umieszczeny na osi X) a wynikiem rozpływ stałych prądów w 
układzie oraz wartości stałych napięć w węzłach.

Opcjonalna analiza OP wykonuje pojedyncze obliczenie punktu 
pracy (punkt pracy jak dla analizy AC).

Analiza DC występuje w kilku formach przemiatania parametrów 
analizy. Analiza może być zagnieżdżona tzn. zmiana parametru 
pierwszego jest wykonywana w pętli wewnętrznej i następuje 
częściej niż parametru drugiego.



Analiza małosygnałowa 

częstotliwościowa AC
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Właściwości analizy:

• jest to analiza liniowa, 

• najpierw obliczany jest punkt pracy,

• następnie linearyzowane są wszystkie elementy nieliniowe 
(zastępowane modelami małosygnałowymi),

• następnie obliczana jest charakterystyka częstotliwościowa,

• wejściami do układu są wszystkie niezależne źródła napięciowe i 
prądowe z niezerową specyfikacją AC,

• wszystkie obliczone wielkości są liczbami zespolonymi.



Analiza czasowa TRAN

22

Właściwości analizy TRAN:

• oblicza zachowanie się układu w czasie, argumentem 
dla analizy jest czas,

• na osi X wyników jest czas

• analiza zawsze rozpoczyna się w czasie równym 0,

• analiza kończy się w czasie Stop time,

• przed rozpoczęciem analizy obliczany jest punkt 
pracy, który może być inny niż dla AC bo mogą być 
inne wartości specyfikacji pobudzeń.



Druga symulacja – 2 x inwerter CMOS
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• Zamykamy wykres z wynikami, schemat oraz ADE L, przy pytaniu o zapis stanu 

odpowiadamy Yes i zapisujemy z domyślnymi opcjami. Zapis stanu symulacji 

umożliwia późniejszy szybki powrót do ostatniej symulacji poprzez odczyt stanu.

• Jeśli nie jest uruchomiony wówczas uruchamiamy Library Manager, 

menu: Tools->Library manager.

• Tworzymy nowy schemat w bibliotece SKN_CHIP przy użyciu Library Manager.

• Menu: File->New->Cell View, wypełniamy jak na rysunku i klikamy OK.

• Otworzy się pusty edytor schematów. Następnie wprowadzamy schemat jak na 

rysunku.

• Tranzystory MOS pobieramy z biblioteki gpdk045. Używamy tranzystorów: nmos1v
oraz pmos1v . Wymiary tranzystorów dla nmos: 200n/45n dla pmos 390n/45n. 

Zasilanie 1.1V, przebieg wejściowy prostokąt 10GHz. 



Druga symulacja – inwertery CMOS c.d.
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Druga symulacja – inwertery CMOS c.d.
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Trzecia symulacja – 2 x inwerter CMOS z 

użyciem testbench’a
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• Zamykamy wykres z wynikami oraz ADE L nie zamykamy schematu, przy pytaniu o 

zapis stanu jak poprzednio odpowiadamy Yes i zapisujemy z domyślnymi opcjami.

• W oknie schematu wybieramy menu: File->Save a Copy. I wypełniamy okno 

dialogowe jak poniżej.

• Poprzez Library Manager otwieramy komórkę inv i modyfikujemy do postaci jak 

na kolejnym rysunku.

• Menu: File->New->Cell View, wypełniamy jak na rysunku i klikamy OK.

• Otworzy się pusty edytor schematów. Następnie wprowadzamy schemat jak na 

rysunku.



Trzecia symulacja – 2 x inwerter CMOS 

z użyciem testbench’a c.d.
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Trzecia symulacja – 2 x inwerter CMOS z 

użyciem testbench’a c.d.
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• Po zapisaniu schematu (przycisk Check and Save    ) wybieramy menu: Create-
>CellView->From Cellview. Pojawią się 2 kolejne okna, wypełniamy je jak na 

rysunkach poniżej i klikamy OK.

• Na tym etapie powinno pojawić się okno wygenerowanego automatycznie symbolu 

inwertera o kształcie prostokąta. Kolejną czynnością jest zmiana kształtu graficznego 

na typowy dla tego rodzaju układu. Na kolejnym rysunku przedstawiono spodziewany 

kształt symbolu.

• Czerwony okalający prostokąt najpierw należy usunąć a na koniec go ponownie 

utworzyć poprzez menu: Create->Selection Box->Automatic.



Trzecia symulacja – 2 x inwerter CMOS z 

użyciem testbench’a c.d.
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• Finalizujemy po zapisaniu symbolu (przycisk Check and Save    ).

• W oknie Library Manager powinny być widoczne dwa widoki komórki inv . 



Trzecia symulacja – 2 x inwerter CMOS z 

użyciem testbench’a c.d.
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• Tworzymy nowy schemat (o nazwie two_inv_tb) zawierający 2 inwertery oraz 

zasilanie i sygnał wejściowy jak na poniższym rysunku.



Trzecia symulacja – 2 x inwerter CMOS z 

użyciem testbench’a c.d.
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• ADE L (menu: Launch -> ADE L) a następnie wczytujemy zapisaną sesję 

poprzedniej symulacji (w oknie ADE L menu: Session -> Load State). W oknie 

zmieniamy pole Cell na poprzednią symulację i klikamy OK. 

• Modyfikujemy ustawienia, jeśli są potrzebne zmiany, i uruchamiamy symulator. 

Symulacje powinny dać identyczne rezultaty jak poprzednio, jednak teraz mamy 

oddzielony projektowany układ os środowiska symulacyjnego i w kolejnym kroku 

możemy przejść do projektu topografii inwertera.



Czwarta symulacja – oscylator 

pierścieniowy
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• Tworzymy nowy schemat (o nazwie ring_osc_tb) zawierający 9 inwerterów oraz 

zasilanie i sygnał pobudzający. Wykonujemy symulację czasową i obserwujemy sygnał 

na kilku węzłach łączących inwertery. Co zaobserwowaliśmy, czy doszło do 

wzbudzenia drgań?



Czwarta symulacja – oscylator 

pierścieniowy c.d.
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• Aby doszło do wzbudzenia drgań 

często niezbędne jest dodanie 

zakłócenia wstępnego. Obok 

przedstawiono jak można to zrobić.



Czwarta symulacja – oscylator 

pierścieniowy c.d.
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